Problema adduser e startx
Moderatore: Staff
Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.
La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.
La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
-
samuelexyz
- Linux 0.x

- Messaggi: 1
- Iscritto il: mar 12 ago 2008, 22:58
Problema adduser e startx
Ragazzi scusate la domanda forse stupida , devo creare un nuovo utente che possa aprire kde ho fatto adduser ho provato a mettergli gli stessi gruppi dell'utente root ma se faccio startx mi da questi errori:
xf86EnableIOPorts : failed to set IOPL for I/O ( Operation not permitted )
giving up.
xinit: Connection reset by peer (errno 104): unable to connect to X server
xinit: No such process (errno 3): Server error.
come posso risolvere? da root comunque funziona tutto alla perfezione
Grazie mille sam
xf86EnableIOPorts : failed to set IOPL for I/O ( Operation not permitted )
giving up.
xinit: Connection reset by peer (errno 104): unable to connect to X server
xinit: No such process (errno 3): Server error.
come posso risolvere? da root comunque funziona tutto alla perfezione
Grazie mille sam
- phobos3576
- Staff

- Messaggi: 2980
- Iscritto il: dom 17 apr 2005, 0:00
- Slackware: 13.1
- Kernel: 2.6.37-smp
- Desktop: KDE 4.5.3
Re: Problema adduser e startx
In ambiente Linux c'è una certa confusione legata alla presenza dei due comandi adduser e useradd; da quanto ho capito io, adduser è un comando il cui comportamento varia da distribuzione a distribuzione, mentre useradd (in coppia con userdel) è il comando standard per gli ambienti Posix-compatibili (come Unix/Linux).
Per renderti indipendente da questi dettagli, ti consiglio di usare (da root) il programma KUser; lo trovi nel menu "K" - "Sistema".
Una volta lanciato KUser, cancella l'utente che hai creato in precedenza e ricrealo di nuovo; ricordati anche di abilitare la directory HOME per il nuovo utente, altrimenti, quando lanci startx ottieni dei messaggi di errore in quanto KDE non può creare i vari file di configurazione.
Per renderti indipendente da questi dettagli, ti consiglio di usare (da root) il programma KUser; lo trovi nel menu "K" - "Sistema".
Una volta lanciato KUser, cancella l'utente che hai creato in precedenza e ricrealo di nuovo; ricordati anche di abilitare la directory HOME per il nuovo utente, altrimenti, quando lanci startx ottieni dei messaggi di errore in quanto KDE non può creare i vari file di configurazione.
- goldy
- Packager

- Messaggi: 1267
- Iscritto il: lun 3 mag 2004, 0:00
- Slackware: Current
- Kernel: 2.6.26.5
- Desktop: KDE 3.5.10
- Località: Bologna
- Contatta:
Re: Problema adduser e startx
io farei in questo modo:
Codice: Seleziona tutto
useradd nomeutente
passwd nomeutente
mkdir /home/nomeutente
chown nomeutente /home/nomeutente
-
birg81
- Linux 3.x

- Messaggi: 760
- Iscritto il: lun 16 gen 2006, 10:57
- Nome Cognome: Biagio
- Slackware: 12.2
- Kernel: 3.4.7
- Desktop: LxDE
- Distribuzione: ArchLinux
- Località: Castellammare di Stabia (NA)
- Contatta:
Re: Problema adduser e startx
il comportamento è strano xke un utente normale puo avviare tranquillamente startx e si avvia l'interfaccia grafica del utente
- phobos3576
- Staff

- Messaggi: 2980
- Iscritto il: dom 17 apr 2005, 0:00
- Slackware: 13.1
- Kernel: 2.6.37-smp
- Desktop: KDE 4.5.3
Re: Problema adduser e startx
What?birg81 ha scritto:il comportamento è strano xke un utente normale puo avviare tranquillamente startx e si avvia l'interfaccia grafica del utente
-
Communico
- Packager

- Messaggi: 200
- Iscritto il: sab 3 mag 2008, 19:59
- Nome Cognome: Stefano Cereda
- Slackware: current
- Kernel: 2.6.29.1
- Desktop: kde 4.2.2
- Località: Seriate (BG)
Re: Problema adduser e startx
Normalmente in slackware ti basta fare adduser e rispondere alle domande che ti vengono poste, poi dall'utente appena creato puoi tranquillamente dare startx senza dover aggiustare nessun permesso...
- cymon
- Linux 2.x

- Messaggi: 430
- Iscritto il: ven 5 gen 2007, 1:40
- Slackware: 13.1
- Kernel: 2.6.33.4-smp
- Desktop: Fluxbox
- Località: Milano
- Contatta:
Re: Problema adduser e startx
Postare la riga del /etc/passwd relativa al nuovo utente potrebbe essere utile...
- aschenaz
- Staff

- Messaggi: 4623
- Iscritto il: mer 28 lug 2004, 0:00
- Nome Cognome: Nino
- Slackware: current
- Kernel: 5.4.x
- Desktop: KDE
- Località: Reggio Calabria
- Contatta:
Re: Problema adduser e startx
Comunque, non c'è bisogno di fare il login da root per usare KUser:
lanciandolo da semplice utente, infatti, compare la finestra "Esegui
come root", in cui ti richiede la password.
lanciandolo da semplice utente, infatti, compare la finestra "Esegui
come root", in cui ti richiede la password.