Pagina 1 di 1
Problema adduser e startx
Inviato: mar 12 ago 2008, 23:08
da samuelexyz
Ragazzi scusate la domanda forse stupida , devo creare un nuovo utente che possa aprire kde ho fatto adduser ho provato a mettergli gli stessi gruppi dell'utente root ma se faccio startx mi da questi errori:
xf86EnableIOPorts : failed to set IOPL for I/O ( Operation not permitted )
giving up.
xinit: Connection reset by peer (errno 104): unable to connect to X server
xinit: No such process (errno 3): Server error.
come posso risolvere? da root comunque funziona tutto alla perfezione
Grazie mille sam
Re: Problema adduser e startx
Inviato: mer 13 ago 2008, 0:04
da phobos3576
In ambiente Linux c'è una certa confusione legata alla presenza dei due comandi adduser e useradd; da quanto ho capito io, adduser è un comando il cui comportamento varia da distribuzione a distribuzione, mentre useradd (in coppia con userdel) è il comando standard per gli ambienti Posix-compatibili (come Unix/Linux).
Per renderti indipendente da questi dettagli, ti consiglio di usare (da root) il programma KUser; lo trovi nel menu "K" - "Sistema".
Una volta lanciato KUser, cancella l'utente che hai creato in precedenza e ricrealo di nuovo; ricordati anche di abilitare la directory HOME per il nuovo utente, altrimenti, quando lanci startx ottieni dei messaggi di errore in quanto KDE non può creare i vari file di configurazione.
Re: Problema adduser e startx
Inviato: mer 13 ago 2008, 0:30
da goldy
io farei in questo modo:
Codice: Seleziona tutto
useradd nomeutente
passwd nomeutente
mkdir /home/nomeutente
chown nomeutente /home/nomeutente
Re: Problema adduser e startx
Inviato: mer 13 ago 2008, 15:27
da birg81
il comportamento è strano xke un utente normale puo avviare tranquillamente startx e si avvia l'interfaccia grafica del utente
Re: Problema adduser e startx
Inviato: mer 13 ago 2008, 15:38
da phobos3576
birg81 ha scritto:il comportamento è strano xke un utente normale puo avviare tranquillamente startx e si avvia l'interfaccia grafica del utente
What?
Re: Problema adduser e startx
Inviato: mer 13 ago 2008, 16:50
da Communico
Normalmente in slackware ti basta fare adduser e rispondere alle domande che ti vengono poste, poi dall'utente appena creato puoi tranquillamente dare startx senza dover aggiustare nessun permesso...
Re: Problema adduser e startx
Inviato: mer 13 ago 2008, 17:10
da cymon
Postare la riga del /etc/passwd relativa al nuovo utente potrebbe essere utile...
Re: Problema adduser e startx
Inviato: mer 13 ago 2008, 17:50
da aschenaz
Comunque, non c'è bisogno di fare il login da root per usare KUser:
lanciandolo da semplice utente, infatti, compare la finestra "Esegui
come root", in cui ti richiede la password.